PHP Depend - Software Metrics for PHP

Version 2.4.1 released

We are proud to announce version 2.4.1 of PDepend. For more details visit the version release site.

The prefered way to install PDepend is as a phar (bz2) archive:

~ $ wget http://static.pdepend.org/php/latest/pdepend.phar

or you can use composer by just adding PHP_Depend as a dependency to your composer.json

{ "require": { "pdepend/pdepend" : "2.4.1" } }

Then install Composer in your project (or download the composer.phar directly):

~ $ curl -s http://getcomposer.org/installer | php

And finally let Composer install the project dependencies:

~ $ php composer.phar install

Download

Download the latest version of PHP_Depend as a Phar archive (bz2) or Composer dependency.

blog comments powered by Disqus Build on CloudBees button